I am stuck, unable to send emails. This was all working fine in development/test and then in production when initially deployed. Then production developed trouble connecting to the SMTP server due to an apparent port requirement change (25 used to work, but now it must be 3535... It is GoDaddy). The simple setup change from 25 to 3535 worked in dev/test.
When I save the SystemSettings on production after changing the port from 25 to 3535, I see the message:
The Page at xxx.xxx.xxx:8080 says:
"unable to start handling incoming or outgoing e-mails due to the following exception outgoingEmail_L3WBCHEM01 (access denied)"
On the server, the log shows:
2015-04-28 14:10:31,541 ERROR -Unable to start e-mail channel for business space L3WBCHEM01. It is possible that SystemSettings object is not initialised.
This entry is then repeated 3 more times consecutively a bit further down after
I also see in the startup sequence:
log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: system.log (Access is denied)
1) Am I simply having a privilege issue I need to resolve with what the server can access?
2) I had recently turned logging on and had to enable access to several props files and the like for it to save. Maybe some lockdown procedure was run on my hosted (VPS) server...
3) currently, no logging is enabled, per the checkboxes in the System Settings/Logging tab.
Other thoughts:
Does anyone know how to simply empty the email queue of all pending emails (wherever it lives that it survives a server reboot)? I can't really have all that accumulated junk start going out after it was otherwise resolved...
Does anyone know what "(access denied)" even means in the context trying to save SystemSettings? (It does save the SystemSettings changes, by the way.)
I have seen before what appeared to be backed up emails in the Java email handling, and I think this may be part of what is happening here.
Thanks in advance!
Roy
AwareIM 6.0 (Developer, build 2030)