This is a tip for anyone else (and a reminder for myself in 3 years time when I face this problem again)
We encountered an issue this week:
- server getting slow to do certain things
- publishing taking a VERY long time
- restart of server and LONG Aware start-up time
- publishing taking so long, it fails, CPU grows to 200% (even after adjusting memory, and having plenty of GB on server), throws Java Heap Space excceeded error or GC limit error
Solution:
- 2 DB tables had grown unusually large:
DV_RES - was 2.9GB
EXECUTION_CONTEXT - was 236MB
take a backup of 2 tables (just in case)
export all BSVs on the server (you will use them below)
shut down Aware
empty the contents of both tables (ie delete all rows)
turn back on Aware and publish all business spaces (if you don't do this you may be Visual Perspective issues when logging in)
Problem solved... can publish again, goes into test very quickly, restart Aware again in normal times