Hi Guys,
I want to upgrade to version 6 but before going the whole hog and upgrading my production server I have decided to do some testing first on my windows laptop. I want to be sure of the effect v6 will have on my clients data / user experience. My production server runs AwareIM version 5.9. So far I have taken the following steps:
1) Installed MySQL on my laptop
2) Installed evaluation AwareIM version 6 on my laptop
Now the best way to test something is to use some real life data so next I took the following steps:
3) Exported a BSV from my production server
4) Created a new BSV with the same name on my laptop and imported the BSV from the step 3
5) Published it and confirmed I could log into the operation mode
All good so far, no probs. However here is the bit that fails for me:
6) I want to use some 'live' data from the production server so I create a backup from within MySQL Workbench. I create the backup but only include the tables that start with MyBusinessSpaceName (I don't include and bas tables apart from bas_idgen)
7) I import this backup on my laptop using MySQL Workbench and it confirms the backup was restored.
8 ) PROBLEM: When I now try to log into the operation mode on my laptop all I get is an error stating that I have entered invalid credentials, even throws the error if I try to log in as the administrator as in step 5.
I have tried restarting awareIM, publishing a new version, publishing a test version all to no a avail. It just won't allow me to log in.
Can anyone spot where I'm going wrong here? Is this because I'm using a MySQL backup that is from a server running AwareIM 5.9 and version 6 won't support it?
Any ideas welcomed,
Many Thanks