Scenario: Users are presented with login screen - and upon login get an error as above. This was originally happening about once a week. Two weeks ago it started happening more frequently - about once every 24 hours. Today it happened after 17 hours.
After reading the other posts in the forum I contacted my VPS hosting provider about the possible DNS issue - definitely not that as my users are accessing via ip address and not DNS - according to my hosting provider.
Logs show the following:
ERROR: transaction commit failed (will call rollback) , ERROR: org.openadaptor.adaptor.jms.JMSSink - txnCommit() failed with JMS Queue/Topic PublishException: org.openadaptor.adaptor.jms.PublishException: org.openadaptor.adaptor.jms.JMSPublisher - commit() failed with JMSException: org.jboss.mq.SpyJMSException: Cannot process a transaction; - nested throwable: (java.io.IOException: Client is not connected) [java.io.IOException: Client is not connected]
Exception thrown com.bas.connectionserver.server.ConnectionException Error processing output message
com.bas.connectionserver.server.ConnectionException: Error processing output message
at com.bas.connectionserver.server.ConnectionFactory.sendMessage(Unknown Source)
at com.bas.webapp.common.WebAppUtils.sendMessageToExecutionEngine(Unknown Source)
at com.bas.webapp.common.WebAppUtils.sendMessageToExecutionEngine(Unknown Source)
at com.bas.webapp.thin.handlers.D.J.A(Unknown Source)
at com.bas.webapp.thin.handlers.D.J.A(Unknown Source)
at com.bas.webapp.thin.handlers.D.J.A(Unknown Source)
at com.bas.webapp.thin.handlers.XMLRequestHandler.A(Unknown Source)
at com.bas.webapp.thin.handlers.XMLRequestHandler.handleURLRequest(Unknown Source)
at com.bas.webapp.thin.servlets.WebInterfaceURLServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:662)
Web server returned error: Error processing output message
Then I ran a diagnostic on the server performance and got the following:
System Performance Diagnostic Report
Warning
Symptom: The system is experiencing excessive paging
Cause: Available memory on the system is low.
Details: The total physical memory on the system is not capable of handling the load.
Resolution: Upgrade the physical memory or reduce system load
My question is: Is something in my AwareIM configuration "breaking" or could this be caused by the memory issue detailed above?
Any ideas? Thanks!