Once more unto the breach ....
I simplified things a bit to see I'd get a better log result.
I have two simple processes
#1 FIND NSCPers WHERE (NSCPers.CO=’Yes’ OR NSCPers.FieldRep=’Yes’ OR NSCPers.RegDir=’Yes’)
Con_Name
#2 NSCPers.NameLine=NSCPers.Rank+’ ‘+NSCPers.FirstName+’ ‘+NSCPers.LastName+’ ‘+NSCPers.Branch
#1 finds 368 instances of NSCPers which is correct. #2 Con_Name processes 35 instances with the log showing, executing the action and the action result which is correct then fails with the message “Access to object NSCPers denied for System”
The last log entry after what appear to be correct entries for 35 instances is the following:
“Exception while executing process Con_Name Exception class=com.bas.connectionserver.server.AccessDeniedException message Access to business object NSCPers is denied for System”
What is the error about and is there anything that will help resolve this? The server and tomcat logs only show the same error being “thrown”.