Hi!
I'm having some HUGE trouble since this afternoon.
My server rebooted because of a power failure on the building, and then when it restarted, aware is "broken"!
I can login in my application but then when i start any window, i can only use it for a few seconds. After this i get this error:
alert
com.bas.connectionserver.server.e
the log says:
WebServlet URL got request with params:
Got XML request <root><start_process_action process_name="CreateLigacao" force_no_collection="false" ></start_process_action></root>
Calling BAS server
Server replied to the original request that some UI operation is required
WebServlet URL got request with params:
WebServlet URL got request with params:
WebServlet URL got request with params:
Exception thrown com.bas.connectionserver.server.e null
com.bas.connectionserver.server.e
at com.bas.connectionserver.server.ConnectionFactory.sendMessage(Unknown Source)
at com.bas.webapp.common.WebAppUtils.sendMessageToExecutionEngine(Unknown Source)
at com.bas.webapp.common.WebAppUtils.sendMessageToExecutionEngine(Unknown Source)
at com.bas.webapp.thin.a.d.j.a(Unknown Source)
at com.bas.webapp.thin.a.d.j.a(Unknown Source)
at com.bas.webapp.thin.a.d.j.a(Unknown Source)
at com.bas.webapp.thin.a.c.a(Unknown Source)
at com.bas.webapp.thin.a.c.a(Unknown Source)
at com.bas.webapp.thin.servlets.WebInterfaceURLServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188-)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108-)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:874)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528-)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
at java.lang.Thread.run(Unknown Source)
It doesn't matter the process that i'm using....it all returns the same error.
I tried these solutions:
Restarted the server
Restarted aware, jboss,tomcat,aware
Shut the services down
Started jboss,tomcat,aware using control panel
Changed the 9000 port to 9010
Changed back the 9010 port to 9000
i'm really desperate....everything was working great...
Hope someone helps[/code]