I am having the same difficulty with the startAwareIMNoGUI.sh script. I am able to start the AwareIM server manually. Startup via system configuration scripts fails with a path error:
/usr/local/AwareIM/bin/startAwareIMNoGUI.sh: line 14: ../JDK/bin/java: No such file or directory
After editting paths in startAwareIMNoGUI.sh and startupOptions.props with the proper full-length pathnames, I get the same error, just later in the startup process:
Process status: Tomcat: Unable to start due to the following exception java.io.IOException java.io.IOException: ../JDK/bin/java: not found
Obviously, there are dependencies on relative paths in the existing configuration. Vladimir from your support department says the bin/ subdirectory must be the pwd of the startup script. I am loathe to put "cd /path/to/AwareIM" in the top of my init scripts; its just bad practice. Ideally, a single environment variable should control the root of all paths, doing away with fragile dependencies on relative path.
Any guidance you can provide in the automatic startup of AwareIM would be appreciated.