I installed AwareIM on SUSE Linux Enterprise 10.2. It uses MySql database. When I start AwareIM server every time, some erros appear as follow:
./startAwareIM.sh
Warning: Cannot convert string "-b&h-lucida-medium-r-normal-sans--140---p--i so8859-1" to type FontStruct
Overall status: Aware IM starting ...
JMS connection: first exception is javax.naming.CommunicationException Receive t imed out
javax.naming.CommunicationException: Receive timed out [Root exception is java.n et.SocketTimeoutException: Receive timed out]
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 95)
at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1375)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:590)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:583)
at javax.naming.InitialContext.lookup(Unknown Source)
at com.bas.install.Pinger.a(Unknown Source)
at com.bas.install.Pinger.if(Unknown Source)
at com.bas.basserver.bsmanager.j.j(Unknown Source)
at com.bas.basserver.bsmanager.j.if(Unknown Source)
at com.bas.basserver.bsmanager.j.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.main(Unknown Source)
Caused by: java.net.SocketTimeoutException: Receive timed out
at java.net.PlainDatagramSocketImpl.receive(Native Method)
at java.net.DatagramSocket.receive(Unknown Source)
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 65)
... 11 more
javax.naming.CommunicationException: Receive timed out [Root exception is java.n et.SocketTimeoutException: Receive timed out]
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 95)
at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1375)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:590)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:583)
at javax.naming.InitialContext.lookup(Unknown Source)
at com.bas.install.Pinger.a(Unknown Source)
at com.bas.install.Pinger.if(Unknown Source)
at com.bas.basserver.bsmanager.j.j(Unknown Source)
at com.bas.basserver.bsmanager.j.if(Unknown Source)
at com.bas.basserver.bsmanager.j.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.main(Unknown Source)
Caused by: java.net.SocketTimeoutException: Receive timed out
at java.net.PlainDatagramSocketImpl.receive(Native Method)
at java.net.DatagramSocket.receive(Unknown Source)
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 65)
... 11 more
JMS connection: last exception is javax.naming.CommunicationException Receive ti med out
Process status: JBoss: Starting...
Starting JBOSS server ../JDK/bin/java -Xmx128m -Djboss.home.dir=../JBoss -class path ../JDK/lib/tools.jar:../JBoss/bin/run.jar org.jboss.Main -c bas
JMS connection: first exception is javax.naming.CommunicationException Receive t imed out
javax.naming.CommunicationException: Receive timed out [Root exception is java.n et.SocketTimeoutException: Receive timed out]
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 95)
at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1375)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:590)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:583)
at javax.naming.InitialContext.lookup(Unknown Source)
at com.bas.install.Pinger.a(Unknown Source)
at com.bas.install.Pinger.if(Unknown Source)
at com.bas.basserver.bsmanager.j.j(Unknown Source)
at com.bas.basserver.bsmanager.j.if(Unknown Source)
at com.bas.basserver.bsmanager.j.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.main(Unknown Source)
Caused by: java.net.SocketTimeoutException: Receive timed out
at java.net.PlainDatagramSocketImpl.receive(Native Method)
at java.net.DatagramSocket.receive(Unknown Source)
at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:12 65)
... 11 more
Process status: JBoss: Active and functional
Process status: Tomcat: Starting...
Starting Tomcat server ../JDK/bin/java -Xmx128m -Djava.endorsed.dirs=../Tomcat/ common/endorsed -classpath ../JDK/lib/tools.jar:../Tomcat/bin/bootstrap.jar -Dca talina.base=../Tomcat -Dcatalina.home=../Tomcat -Djava.io.tmpdir=../Tomcat/temp org.apache.catalina.startup.Bootstrap start
Connecting to URL http://localhost:8060
Connection to URL: first exception is Connection refused
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at sun.net.NetworkClient.doConnect(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.<init>(Unknown Source)
at sun.net.www.http.HttpClient.<init>(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Sour ce)
at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
at com.bas.install.Pinger.a(Unknown Source)
at com.bas.install.Pinger.if(Unknown Source)
at com.bas.basserver.bsmanager.j.f(Unknown Source)
at com.bas.basserver.bsmanager.j.if(Unknown Source)
at com.bas.basserver.bsmanager.j.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.a(Unknown Source)
at com.bas.controlcenter.ControlCenterApp.main(Unknown Source)
Process status: Tomcat: Active and functional
Process status: Aware IM Server: Starting...
Do the errors effect AwareIM functions? Recently, I was troubled by a problem -- I compiled the SimpleProcess example from the Programmers Reference and integrated the jar file into Aware all followed steps described in Programmers Reference. But I always got error message:
Process implementation component com.bd.awareim.SimpleProcess is not found or has invalid format
I have discussed this issue with aware_support ( please see https://forum.awareim.com/viewtopic.php?p=16148#16148). The problem is still there. Maybe form the server starting errors, you can find something that may be able to help to resovle the problem.
Thanks,
Mojun