I'm having trouble connecting the Configuration Tool from a remote computer to the AwareIM Server.
This is my scenario:
- I've performed a standard installation (AwareIM Server, AwareIM Application and Configuration Tool with Derby) on a local Server (Windows XP machine) using the CRM Business Space Template.
- I've enabled all ports on the Server as instructed in the installation guide.
- I'm able to connect locally on the Server to the CRM Application.
- I'm able to connect locally on the Server to the Configuration Tool.
- I've performed an installation of the stand-alone Configuration Tool on the "remote" computer (Windows XP), within the same subnet. When asked for the server's network name I specified the Server's IP address (e.g. 192.168.1.81).
- I've enabled all ports on the remote computer as instructed in the installation guide.
- I'm able to connect from the remote computer to the application on the Server.
- I'm NOT able to connect from the remote computer to the Server via the Configuration Tool.
As soon as I start the Configuration Tool, I enter "CRM" as Business Space, and "admin" and "password" as credentials.
At this point, I already noted a small difference: the Business Space is a simple text field, not a drop-down such as the one that appears when signing on locally on the Server.
After that, I get the following message:
Error establishing connection with the server. ERROR: org.openadaptor.adaptor.jms.JMSSink - intit() failed with JMS Queue/Topic PublishException: org.openadaptor.adaptor.jms.PublishException: org.openadaptor.adaptor.jms.JMSPublisher - connect() failed with NamingException: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out]
What am I missing?
...