Ok here is some additional information after troubleshooting.
Test Server:
- Windows 2008 R2 64bit, with 16gb MEM, 16 cores
- Java 4 for Aware, Java 6 for Tomcat (due to need of agent)
After we began not begin able to start-up aware via the Configuration Panel. We installed as a service, restarted server and all came up fine.
So we decided to un-install the service and run startAwareIM.bat
and that again failed to start
So we then tried startAwareIMc.bat which actually began to start and we were able to see a JBoss error.
"Could not reserve enough space for object heap"
Tracing this back to other many known issues when Java 32bit and 64bit are trying to use UNDER 2gb limit (for 32) and above (2048 for 64)
Current Quick Fix:
We limited all JBoss, Tomcat and Aware to each 1024 megs until we find out if this is in fact an issue or we need to "tune" our Java "heap" sizes better
When we find solution we will post in Tips and Tricks