Exception changing business space version Aware IM server encountered the following error .Error persisting business space Coul not find stored procedure '#jtds00003'.
This problem results when:
The length of an Attribute is changed and Data truncation could occur. For eg: Length of sDescription = 50 and is changed to sDescription=10 for example.
Should you have a published bsv, it warns you that data may be truncated occur and should you publish the modification it will most likely clear all data from the corresponding field in the Live DB, however when you have Data in the Test DB that could be truncated, and you try to test it returns the Above mentioned Error. Hence when you drop all initial data it will resolve the problem
Hope this helps all who may come across this error.