An addition to my earlier post.
As was probably clear from the screenshot, I tried to set the OAuth settings ‘non-dynamic’ in the configurator, i.e. open the BS version, select ‘Outgoing emails’ from the Properties pane, tick ‘OAuth support’ and then ‘Settings’.
As an alternative, I looked at the possibility to define the settings in the SystemSettings object. After choosing the option “Use values from SystemSettings object”, I ticked “Add attributes for OAuth support to the SystemSettings object”. This resulted in a lot of “OA_” attributes in the SystemSettings, but I do not see any attribute that controls the grant type (OAuth flow), being Authorization Code or Client Credentials, so it seems that only the Authorization Code flow will be used and it is not possible to use the Client Credentials instead.
Also, when using the SystemSettings I don’t see a way to control whether the email channel uses the OAuth at all. It seems that once the relevant OAuth attributes are added to the SystemSettings, Aware assumes that OAuth must be used and there is no way to tell it to ignore those settings and to send an email without OAuth flow. Also, I could not delete any of those OA_ attributes in SystemSettings (results in an error “Deletion of this attribute is not allowed”), even though those SystemSettings attributes were not used for the outgoing email and not even after I removed all email communication for all objects in the business space.
All in all, it seems that there is still some work to do to support OAuth communication for outgoing emails. I hope that this can be fixed because OAuth is becoming increasingly used or required for cloud services.